Is there no way to use Tweetinvi in .NET project targeting Framework 3.5?

May 30, 2014 at 3:19 PM
Hi,
My project is targeting .NET Framework 3.5. Is there no way to use TweetInvi with it?

Harry
May 31, 2014 at 1:10 PM
Hi,

Tweetinvi is not available for .NET Framework 3.5. You are not the first one to ask me for this.
Tweetinvi is a Portable Class Library, it means that it is the only Twitter C# library that is totally for Windows, Windows RT, Windows Phone, Mono…

To do this I had to get rid of .NET Framework 3.5 which is today getting “old”. There are very rare reasons to use .NET Framework 3.5 and the main reason is when you want to use Tweetinvi in a Unity 3D project that is available in 3.5.

If you want to use Tweetinvi, I would recommend to use a WebService (even locally). You can consequently have a WCF project in .NET 4.0/4.5 and expose endpoints for the Tweetinvi methods that are willing to use. At such point you can access your WebService from your .NET 3.5 application.

I would also recommend not to use 3.5 even if you do not always have the choice. You need to remember that for your development using 4.5 will allow you to reuse your code in Windows Phone/Windows RT!

Hope this helps.
Linvi
Marked as answer by linvi on 6/2/2014 at 9:52 AM
Jun 3, 2014 at 2:08 PM
We have recently been reviewing our own target frameworks for our applications and note that even Windows XP (which is not even supported any longer) is Framework 4 compatible. There should really be no reason to be tied to Framework 3.5.