GetUserTimeline problem

Jun 4, 2014 at 1:52 PM
I loved the user.GetUserTimeline(maxnumberoftweets,includereplies) in version 0.9.2.2 but it seems to not work any more.

From your examples I execute the following and get 200 tweets (which I think is the max)
private static void Timeline_GetUserTimeline(string username)
    {
        var user = User.GetUserFromScreenName(username);

        var timelineTweets = user.GetUserTimeline(300,false);
        foreach (var tweet in timelineTweets)
        {
            Console.WriteLine(tweet.Text);
        }
    }

But in the latest version (0.9.3.2) - it doesn't seem to be possible to execute the GetUserTimeLine with 2 parms - so I use the code below. But now I only get 121 tweets. I am simply never able to get 200 tweets with the new version, with or without include_replies set to 0.

Could you bring back the old functionality which worked so brilliant, or provide a workaround, please.

var user = User.GetUserFromId(ssUid);
                    var timelineParameter = Timeline.CreateUserTimelineRequestParameter(ssUid);
                    timelineParameter.ExcludeReplies = true;
                    timelineParameter.MaximumNumberOfTweetsToRetrieve = 1000;
                    var tweets = user.GetUserTimeline(timelineParameter);
Thank you for a great product.
Coordinator
Jun 4, 2014 at 2:34 PM
Hi,

This is in fact half an issue but I will work on this. The reason is that the IncludeRTS parameter is set to false by default.
And as described in the documentation, it will remove the retweets but keep counting them as if they were in the result.

It basically means that you are currently receiving 121 concrete tweets and 79 retweets are ignored. The retweets are not sent by Twitter because the parameter is set to false. Twitter says that it returned 200 tweets even if the 79 retweets were ignored.
In order to have the correct number of tweets (and the result set will contain retweets just set the parameter).
timelineParameter.IncludeRTS = true;
I hope what I am trying to explain make any sense.
For the next release I will set the parameter as true by default because most people will get confused otherwise.
I will also try to think of a way to overcome this crazy (another one) "by design" feature of Twitter.

Associated Work Item

Linvi
Jun 4, 2014 at 3:09 PM
Hi,

Thank you for your prompt reply.

I fully understand.

I now use a work-around whereby I make additional requests using the maxId parm and set it to the minimum value of the first result set.

Once again thanks for a great product!!
Coordinator
Jun 4, 2014 at 3:58 PM
Thank you I appreciate it :)