Windows 8 and Visual Studio 2012 Express for Win 8 Help

Oct 26, 2014 at 8:26 PM
Hi, I'm running Windows 8 and Visual Studio Express 2012 for Windows 8. I've created a new project, and used nuget console: PM> Install-Package TweetinviAPI (the usual course)

nuget determined that version is compatible. However, i'm facing an issue with Autofac dependency on version while 3.5.2 is latest. I've tried to add app.config file to the project to bypass this warning. However, it resulted in fatal error "App can't be started".

Also, i've tried to add dlls manually from latest binaries, but not compatible with visual studio.

Would you please help? Any ideas? Thanks
Oct 27, 2014 at 3:17 PM
Well, I've managed to move code to VS 2012 by creating new solution with same structure and adding code files with some tweaking for system.reflection related code. It works fine now.

However, it seems there is a bug related to thread credential, as it shows null after every call to tweetinvi API, i'm not sure whats the root cause. However, i've added null check for thread credential and set it to application credential if true.

        var loggedUser = await UserAsync.GetLoggedUser();
        var tweetLists = await TweetListAsync.GetUserLists(loggedUser, true);
// thread credentials show null after returning from the above call (not sure why) Anyway, set it to application credentials and next call succeed
        if (TwitterCredentials.Credentials == null)
            TwitterCredentials.Credentials = TwitterCredentials.ApplicationCredentials;

        var friends = await loggedUser.GetFriendsAsync();
I haven't started investigating authentication module yet, but will update this thread if found root cause. Thanks
Oct 29, 2014 at 2:35 PM
Hi there,

I have just spotted a bug affecting all async methods. I will release a bug fix in the coming days.

Thank you for reporting the problem.
Oct 29, 2014 at 2:41 PM
Marked as answer by wtamimi on 11/8/2014 at 11:51 AM