First time user

Apr 19, 2015 at 9:07 PM
Just installed the Nuget package to VS3013 Professional. Create a new class, within that class I have added:


in my usings I have:
using Tweetinvi;

When I build, I get "The name 'TwitterCredentials' does not exits in the current context. Ditto for "Tweet". Tooltips thinks otherwise.

Is there a setting that I'm missing? My references appear to have what I need, Tweetinvi, .Credentials, .Core etc.
Apr 20, 2015 at 1:14 AM
Well, you need to add using statements to reference the appropriate namespace.

Here is a bunch of them, you will probably not need all of these.
using Tweetinvi;
using Tweetinvi.Core;
using Tweetinvi.Core.Enum;
using Tweetinvi.Core.Extensions;
using Tweetinvi.Core.Interfaces;
using Tweetinvi.Core.Interfaces.Controllers;
using Tweetinvi.Core.Interfaces.DTO;
using Tweetinvi.Core.Interfaces.DTO.QueryDTO;
using Tweetinvi.Core.Interfaces.Models;
using Tweetinvi.Core.Interfaces.Models.Parameters;
using Tweetinvi.Core.Interfaces.oAuth;
using Tweetinvi.Core.Interfaces.Streaminvi;
using Tweetinvi.Json;
using Stream = Tweetinvi.Stream;
Apr 20, 2015 at 2:10 AM
Very odd. As I said, I did have the one using for just the tweetinvi, according to the intellisense that should have worked. But, I'm willing. I added all the Tweetinvi.core usings that you listed above.

VS2013 then tells me that Core doesn't exist in the Tweetinvi namespace. That leads me to believe that I didn't install the right package. I installed by using the Nuget Package manage console:
PM> Install-package Tweetinviapi

The reply was Successfully installed 'TweetinviAPI'
It added to the correct project and also installed
Newtonsoft.Json 6.0.8
Autofac 3.5.2
Microsoft.Bcl.Async 1.0.168
Microsoft.Bcl 1.1.10
Microsoft.Net.Http 2.2.29

Is there a problem with the Nuget package manager installation?
Apr 20, 2015 at 2:51 AM
Ok, I Uninstalled the nugget package and just went with the downloaded dlls. Got the same result. I then decided to change my target framework from .NET 4.0 to 4.5. The usings then worked fine and I was able to build.

The documentation said a minimum .Net Framework of 4.0. I guess that changed?

Apr 20, 2015 at 12:07 PM

I will check that nothing has gone wrong with the build but you should be able to use the application with .NET 4.0.
I'll get back to you probably tomorrow. I will have a very busy day today.

Apr 21, 2015 at 11:23 AM

I have just tested the latest version and Tweetinvi is working properly with .NET 4.0 application.
What type of application did you try to use?

Apr 21, 2015 at 3:25 PM
I decided to put what I needed from your API into a separate library, then I created a new wpf project. It worked perfectly. Then I used the library in my real project and it failed. There is something in my real project that conflicts with something in your library. Since my real project if very old and has gone through a lot of reference changes over the years, I'm going to transfer the code to a new wpf project and get rid of references that are dated and that I don't need. I'm certain that will fix the problem.