Trying to create a stream - autofac throws error

May 27, 2015 at 9:35 PM
The requested service 'Tweetinvi.Core.Interfaces.Streaminvi.IFilteredStream' has not been registered. To avoid this exception, either register a component to provide the service, check for service registration using IsRegistered(), or use the ResolveOptional() method to resolve an optional dependency.
Caused by any stream attempt
           try
            {
                var us = Stream.CreateUserStream();

                us.MessageReceived += (s, a) =>
                {
                    Console.WriteLine("You received the message : {0}", a.Message.Text);
                };

                us.FollowedUser += userStream_FollowedUser;
                us.FollowedByUser += userStream_FollowedByUser;
                us.StopStream();
            }
            catch (Exception e1)
            {

            }

            try
            {
                var ts = Stream.CreateTweetStream();
                ts.TweetReceived += ts_TweetReceived;
            }
            catch (Exception e2)
            {
            }
            try
            {
                var fs = Stream.CreateFilteredStream();
                fs.AddFollow(dbAc.UserId);
                fs.MatchingTweetReceived += fs_MatchingTweetReceived;
            }
            catch (Exception e3)
            {
            }
            try
            {
                var ss = Stream.CreateSampleStream();
                ss.TweetReceived += ss_TweetReceived;
            }
            catch (Exception e4)
            {
            }
Is there some setup involved for using streams?
Coordinator
May 28, 2015 at 11:42 AM
Do you have this issue with the latest version of Tweetinvi?
Could you share the StackTrace and the InnerException details please?

Linvi
May 28, 2015 at 3:33 PM
Do you have this issue with the latest version of Tweetinvi?
Didn't think about that, let me check. Am probably on an old version.

Might as well close this issue as it will take me a while to update and test the new version as I had lots of problems getting it to work on Windows7 with all the various versions of VS (express windows, desktop, community). Will have to try and remember what I had todo


Thanks
Coordinator
May 29, 2015 at 9:30 AM
Hi,

I have tried your code as well as each of the different stream and they all work fine.
Before updating please wait for the new release (0.9.8.0) that is coming today or tomorrow.

Cheers,
Linvi